PyPI: tensorflow

CVE-2020-26266

Safety vulnerability ID: SFTY-20201210-55859

Safety legacy ID: pyup.io-39408

TensorFlow versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0 includes a fix for CVE-2020-26266: In affected versions and under certain cases a saved model can trigger use of uninitialized values during code execution. This is caused by having tensor buffers filled with the default value of the type but forgetting to default initialize the quantized floating point types in Eigen.

Created at: Jul 5, 2026Updated at: Jul 5, 2026

Overview

Uninitialized memory access in TensorFlow

Advisory

TensorFlow versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0 includes a fix for CVE-2020-26266: In affected versions and under certain cases a saved model can trigger use of uninitialized values during code execution. This is caused by having tensor buffers filled with the default value of the type but forgetting to default initialize the quantized floating point types in Eigen.

Affected Package

Affecting tensorflow package, versions<1.15.5>=2.0.0a0,<2.0.4>=2.1.0rc0,<2.1.3>=2.2.0rc0,<2.2.2>=2.3.0rc0,<2.3.2>=2.4.0rc0,<2.4.0

Also affects

---

How to Fix

Upgradetensorflowto1.15.52.0.42.1.32.2.22.3.22.4.0or higher.

Mitigation and Workarounds

---

Vulnerable Functions

Functions linked to known vulnerabilities.

Vulnerable function data is available for Enterprise customers

Book a call with us to see Safety in action.

Safety

Verified by Safety

Our Cybersecurity Intelligence Team reviewed this vulnerability. We combine public data with our own research to find issues not yet reported to public sources.

Learn more