PyPI: tensorflow

CVE-2022-41885

Safety vulnerability ID: SFTY-20221118-23962

Safety legacy ID: pyup.io-51944

Tensorflow 2.8.4, 2.9.3 and 2.10.1 include a fix for CVE-2022-41885: When 'tf.raw_ops.FusedResizeAndPadConv2D' is given a large tensor shape, it overflows. https://github.com/tensorflow/tensorflow/security/advisories/GHSA-762h-vpvw-3rcx

Created at: Jul 5, 2026Updated at: Jul 5, 2026

Overview

Overflow in `FusedResizeAndPadConv2D`

Advisory

Tensorflow 2.8.4, 2.9.3 and 2.10.1 include a fix for CVE-2022-41885: When 'tf.raw_ops.FusedResizeAndPadConv2D' is given a large tensor shape, it overflows. https://github.com/tensorflow/tensorflow/security/advisories/GHSA-762h-vpvw-3rcx

Affected Package

Affecting tensorflow package, versions<2.8.4>=2.9.0rc0,<2.9.3>=2.10.0rc0,<2.10.1

Also affects

---

How to Fix

Upgradetensorflowto2.8.42.9.32.10.1or higher.

Mitigation and Workarounds

---

Vulnerable Functions

Functions linked to known vulnerabilities.

Vulnerable function data is available for Enterprise customers

Book a call with us to see Safety in action.

Safety

Verified by Safety

Our Cybersecurity Intelligence Team reviewed this vulnerability. We combine public data with our own research to find issues not yet reported to public sources.

Learn more