PyPI: tensorflow-intel

CVE-2022-41893

Safety vulnerability ID: SFTY-20221118-31177

Safety legacy ID: pyup.io-56525

Tensorflow-intel 2.8.4, 2.9.3 and 2.10.1 include a fix for CVE-2022-41893: If 'tf.raw_ops.TensorListResize' is given a nonscalar value for input 'size', it results 'CHECK' fail which can be used to trigger a denial of service attack. https://github.com/tensorflow/tensorflow/security/advisories/GHSA-67pf-62xr-q35m

Created at: Jul 5, 2026Updated at: Jul 5, 2026

Overview

`CHECK_EQ` fail in `tf.raw_ops.TensorListResize`

Advisory

Tensorflow-intel 2.8.4, 2.9.3 and 2.10.1 include a fix for CVE-2022-41893: If 'tf.raw_ops.TensorListResize' is given a nonscalar value for input 'size', it results 'CHECK' fail which can be used to trigger a denial of service attack. https://github.com/tensorflow/tensorflow/security/advisories/GHSA-67pf-62xr-q35m

Affected Package

Affecting tensorflow-intel package, versions<2.8.4>=2.9.0rc0,<2.9.3>=2.10.0rc0,<2.10.1

Also affects

---

How to Fix

Upgradetensorflow-intelto2.10.0.dev202207282.10.0.dev202207282.10.1or higher.

Mitigation and Workarounds

---

Vulnerable Functions

Functions linked to known vulnerabilities.

Vulnerable function data is available for Enterprise customers

Book a call with us to see Safety in action.

Safety

Verified by Safety

Our Cybersecurity Intelligence Team reviewed this vulnerability. We combine public data with our own research to find issues not yet reported to public sources.

Learn more