PyPI: intel-tensorflow

CVE-2020-15190

Safety vulnerability ID: SFTY-20200925-10055

Safety legacy ID: pyup.io-57038

Intel-tensorflow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1 include a fix for CVE-2020-15190: In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the "tf.raw_ops.Switch" operation takes as input a tensor and a boolean and outputs two tensors. Depending on the boolean value, one of the tensors is exactly the input tensor whereas the other one should be an empty tensor. However, the eager runtime traverses all tensors in the output. Since only one of the tensors is defined, the other one is "nullptr", hence we are binding a reference to "nullptr". This is undefined behavior and reported as an error if compiling with "-fsanitize=null". In this case, this results in a segmentation fault The issue was patched in commit da8558533d925694483d2c136a9220d6d49d843c https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4g9f-63rx-5cw4

Created at: Jul 5, 2026Updated at: Jul 5, 2026

Overview

Segfault in Tensorflow

Advisory

Intel-tensorflow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1 include a fix for CVE-2020-15190: In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the "tf.raw_ops.Switch" operation takes as input a tensor and a boolean and outputs two tensors. Depending on the boolean value, one of the tensors is exactly the input tensor whereas the other one should be an empty tensor. However, the eager runtime traverses all tensors in the output. Since only one of the tensors is defined, the other one is "nullptr", hence we are binding a reference to "nullptr". This is undefined behavior and reported as an error if compiling with "-fsanitize=null". In this case, this results in a segmentation fault The issue was patched in commit da8558533d925694483d2c136a9220d6d49d843c https://github.com/tensorflow/tensorflow/security/advisories/GHSA-4g9f-63rx-5cw4

Affected Package

Affecting intel-tensorflow package, versions<1.15.4>=2.0.0a0,<2.0.3>=2.1.0a0,<2.1.2>=2.2.0a0,<2.2.1>=2.3.0a0,<2.3.1

Also affects

---

How to Fix

Upgradeintel-tensorflowto2.4.02.4.02.4.02.4.02.4.0or higher.

Mitigation and Workarounds

---

Vulnerable Functions

Functions linked to known vulnerabilities.

Vulnerable function data is available for Enterprise customers

Book a call with us to see Safety in action.

Safety

Verified by Safety

Our Cybersecurity Intelligence Team reviewed this vulnerability. We combine public data with our own research to find issues not yet reported to public sources.

Learn more