PyPI: hvac

CVE-2024-37568

Safety vulnerability ID: SFTY-20240609-42190

Safety legacy ID: pyup.io-71665

Due to security concerns, hvac 2.3.0 updates its Authlib dependency from ^1.0.1 to ^1.3.1 to address CVE-2024-37568.

Created at: Jul 5, 2026Updated at: Jul 5, 2026

Overview

Due to security concerns, hvac 2.3.0 updates its Authlib dependency from ^1.0.1 to ^1.3.1 to address CVE-2024-37568.

Advisory

Due to security concerns, hvac 2.3.0 updates its Authlib dependency from ^1.0.1 to ^1.3.1 to address CVE-2024-37568.

Affected Package

Affecting hvac package, versions<2.3.0

Also affects

---

How to Fix

Upgradehvacto2.3.0or higher.

Mitigation and Workarounds

---

Vulnerable Functions

Functions linked to known vulnerabilities.

Vulnerable function data is available for Enterprise customers

Book a call with us to see Safety in action.

Safety

Verified by Safety

Our Cybersecurity Intelligence Team reviewed this vulnerability. We combine public data with our own research to find issues not yet reported to public sources.

Learn more