PyPI: jupyter-server-proxy

CVE-2024-35225

Safety vulnerability ID: SFTY-20240611-84050

Safety legacy ID: pyup.io-71837

Affected versions of Jupyter Server Proxy allow users to run arbitrary external processes alongside their notebook server and provide authenticated web access to them. A reflected cross-site scripting (XSS) issue exists in the /proxy endpoint, which accepts a host path segment in the format /proxy/<host>. When called with an invalid host value, jupyter-server-proxy replies with a response that includes the value of host without sanitization. This allows a third-party actor to send a phishing link with an invalid host value containing custom JavaScript to a user. When the user clicks the link, the browser renders the response, running the custom JavaScript. This issue permits extensive access to the user's JupyterLab instance for an actor. Patches are available, and as a workaround, server operators can disable the jupyter-server-proxy extension.

Created at: Jul 5, 2026Updated at: Jul 5, 2026

Overview

Jupyter Server Proxy has a reflected XSS issue in host parameter

Advisory

Affected versions of Jupyter Server Proxy allow users to run arbitrary external processes alongside their notebook server and provide authenticated web access to them. A reflected cross-site scripting (XSS) issue exists in the /proxy endpoint, which accepts a host path segment in the format /proxy/<host>. When called with an invalid host value, jupyter-server-proxy replies with a response that includes the value of host without sanitization. This allows a third-party actor to send a phishing link with an invalid host value containing custom JavaScript to a user. When the user clicks the link, the browser renders the response, running the custom JavaScript. This issue permits extensive access to the user's JupyterLab instance for an actor. Patches are available, and as a workaround, server operators can disable the jupyter-server-proxy extension.

Affected Package

Affecting jupyter-server-proxy package, versions>=3.0.0rc1,<3.2.4>=4.0.0,<4.2.0

Also affects

---

How to Fix

Upgradejupyter-server-proxyto3.2.44.2.0or higher.

Mitigation and Workarounds

---

Vulnerable Functions

Functions linked to known vulnerabilities.

Vulnerable function data is available for Enterprise customers

Book a call with us to see Safety in action.

Safety

Verified by Safety

Our Cybersecurity Intelligence Team reviewed this vulnerability. We combine public data with our own research to find issues not yet reported to public sources.

Learn more