PyPI: python

CVE-2022-25236

Safety vulnerability ID: SFTY-20220216-00907

Safety legacy ID: pyup.io-51864

Python 3.7.13, 3.8.13, 3.9.11 and 3.10.3 update bundled libexpat version to v2.4.6 to include security fixes.

Created at: Oct 14, 2026Updated at: Oct 14, 2026

Overview

Python 3.7.13, 3.8.13, 3.9.11 and 3.10.3 update bundled libexpat version to v2.4.6 to include security fixes.

Advisory

Python 3.7.13, 3.8.13, 3.9.11 and 3.10.3 update bundled libexpat version to v2.4.6 to include security fixes.

Affected Package

Affecting python package, versions<3.7.13>=3.8.0a0,<3.8.13>=3.9.0a0,<3.9.11>=3.10.0a0,<3.10.3

Also affects

---

How to Fix

We recommend updating python to the latest non-vulnerable version.

Mitigation and Workarounds

---

Vulnerable Functions

Functions linked to known vulnerabilities.

Vulnerable function data is available for Enterprise customers

Book a call with us to see Safety in action.

Safety

Verified by Safety

Our Cybersecurity Intelligence Team reviewed this vulnerability. We combine public data with our own research to find issues not yet reported to public sources.

Learn more