PyPI: tensorflow-rocm

CVE-2022-35939

Safety vulnerability ID: SFTY-20220916-42025

Safety legacy ID: pyup.io-57593

Tensorflow-rocm 2.7.4, 2.8.3 and 2.9.2 include a fix for CVE-2022-35939: OOB write in 'scatter_nd' op in TF Lite. https://github.com/tensorflow/tensorflow/security/advisories/GHSA-ffjm-4qwc-7cmf

Created at: Jul 5, 2026Updated at: Jul 5, 2026

Overview

TensorFlow vulnerable to OOB write in `scatter_nd` in TF Lite

Advisory

Tensorflow-rocm 2.7.4, 2.8.3 and 2.9.2 include a fix for CVE-2022-35939: OOB write in 'scatter_nd' op in TF Lite. https://github.com/tensorflow/tensorflow/security/advisories/GHSA-ffjm-4qwc-7cmf

Affected Package

Affecting tensorflow-rocm package, versions<2.7.4>=2.8.0rc0,<2.8.3>=2.9.0rc0,<2.9.2

Also affects

---

How to Fix

Upgradetensorflow-rocmto2.7.42.8.32.9.2or higher.

Mitigation and Workarounds

---

Vulnerable Functions

Functions linked to known vulnerabilities.

Vulnerable function data is available for Enterprise customers

Book a call with us to see Safety in action.

Safety

Verified by Safety

Our Cybersecurity Intelligence Team reviewed this vulnerability. We combine public data with our own research to find issues not yet reported to public sources.

Learn more