PyPI: tensorflow-macos

CVE-2022-41909

Safety vulnerability ID: SFTY-20221118-67185

Safety legacy ID: pyup.io-58273

Tensorflow 2.8.4, 2.9.3 and 2.10.1 include a fix for CVE-2022-41909: An input 'encoded' that is not a valid 'CompositeTensorVariant' tensor will trigger a segfault in 'tf.raw_ops.CompositeTensorVariantToComponents'. https://github.com/tensorflow/tensorflow/security/advisories/GHSA-rjx6-v474-2ch9

Created at: Jul 5, 2026Updated at: Jul 5, 2026

Overview

Segfault in `CompositeTensorVariantToComponents`

Advisory

Tensorflow 2.8.4, 2.9.3 and 2.10.1 include a fix for CVE-2022-41909: An input 'encoded' that is not a valid 'CompositeTensorVariant' tensor will trigger a segfault in 'tf.raw_ops.CompositeTensorVariantToComponents'. https://github.com/tensorflow/tensorflow/security/advisories/GHSA-rjx6-v474-2ch9

Affected Package

Affecting tensorflow-macos package, versions<2.8.4>=2.9.0rc0,<2.9.3>=2.10.0rc0,<2.10.1

Also affects

---

How to Fix

Upgradetensorflow-macosto2.11.02.11.02.11.0or higher.

Mitigation and Workarounds

---

Vulnerable Functions

Functions linked to known vulnerabilities.

Vulnerable function data is available for Enterprise customers

Book a call with us to see Safety in action.

Safety

Verified by Safety

Our Cybersecurity Intelligence Team reviewed this vulnerability. We combine public data with our own research to find issues not yet reported to public sources.

Learn more