PyPI: apache-superset

CVE-2024-27315

Safety vulnerability ID: SFTY-20240228-96372

Safety legacy ID: pyup.io-68480

An authenticated user with privileges to create Alerts on Alerts & Reports has the capability to generate a specially crafted SQL statement that triggers an error on the database. This error is not properly handled by Apache Superset and may inadvertently surface in the error log of the Alert exposing possibly sensitive data.

Created at: Jul 5, 2026Updated at: Jul 5, 2026

Overview

Apache Superset: Improper error handling on alerts

Advisory

An authenticated user with privileges to create Alerts on Alerts & Reports has the capability to generate a specially crafted SQL statement that triggers an error on the database. This error is not properly handled by Apache Superset and may inadvertently surface in the error log of the Alert exposing possibly sensitive data.

Affected Package

Affecting apache-superset package, versions>=0,<3.0.4>=3.1.0rc1,<3.1.1

Also affects

---

How to Fix

Upgradeapache-supersetto3.0.43.1.1or higher.

Mitigation and Workarounds

---

Vulnerable Functions

Functions linked to known vulnerabilities.

Vulnerable function data is available for Enterprise customers

Book a call with us to see Safety in action.

Safety

Verified by Safety

Our Cybersecurity Intelligence Team reviewed this vulnerability. We combine public data with our own research to find issues not yet reported to public sources.

Learn more